Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Geocaching-Logs und -Listings zu Statistik-Webseiten und Opencaching konvertieren

Moderatoren: fogg, HSCA, Lapu-Lapu

Antworten
Benutzeravatar
geomitast
Geocacher
Beiträge: 106
Registriert: Mi 1. Aug 2012, 16:12

Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von geomitast » So 25. Mär 2018, 19:05

:hilfe: :hilfe: :hilfe: :hilfe:
Seit Neuem habe ich mit der Version 2.93c das Problem, dass angeblich falsche oder fehlerhafte Felder in der cache.txt seien. Weiter können einige Ordner nicht umbenannt werden. Ob hier ein Zusammenhang besteht weiß ich nicht. Vor allem stört mich jedoch die Meldung mit den Feldern. Geolog läuft zwar durch, es gibt aber anschließend mit OCprop auf Grund dieser "Felder" Probleme.
Weiter wird bei einem Cache der Name in der cache.txt nicht gefunden. Dieser ist jedoch m.E. richtig vorhanden.
Der Cache ist GC6180M.

Vielleicht hat ja jemand Lust und Zeit mir mit diesen Ärgerlichkeiten zu helfen.

Schon mal schönen Dank und eine schöne Cache-Saison.

Werbung:
hjoe
Geocacher
Beiträge: 51
Registriert: Mo 6. Apr 2015, 10:46
Kontaktdaten:

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von hjoe » So 25. Mär 2018, 19:35

Aktuell ist Version 2.93e.
Bitte erst mal damit Versuchen.
mfg Heinz

Benutzeravatar
geomitast
Geocacher
Beiträge: 106
Registriert: Mi 1. Aug 2012, 16:12

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von geomitast » So 25. Mär 2018, 22:28

Danke für den Hinweis.
Bei uns war langer Winter und somit lange Cachepause! ;-)
Gibts die zum Download oder muss händisch angepasst werden?
Wo finde ich evtl. Infos?

Vielen Dank für die Info!!


Benutzeravatar
geomitast
Geocacher
Beiträge: 106
Registriert: Mi 1. Aug 2012, 16:12

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von geomitast » Mo 26. Mär 2018, 10:51

Mist!
Im Winter haben auch die Augen gelitten.
Ich habe doch schon die 2.93e! :irre: :kopfwand:
Trotzdem habe ich sie nochmal geladen und mit dieser probiert.
Das Ergebniss ist unverändert. (siehe Anhang)

Das Problem mit dem Umbenennen (Rechtesache bei mir) und dem Namen (erneuter Download des Caches) konnte ich lösen.
Die fehlerhaften Felder sind geblieben.
Das müsste aber doch auch bei anderen auftreten!?
Ich vermute, dass da GC-Inhalte in die "Attribute" rutschen!?

Bitte helfen! :hilfe:

Schon mal vielen Dank.
Dateianhänge
geolog_293e.jpg
geolog_293e.jpg (304.88 KiB) 765 mal betrachtet

Benutzeravatar
geomitast
Geocacher
Beiträge: 106
Registriert: Mi 1. Aug 2012, 16:12

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von geomitast » Mo 26. Mär 2018, 10:59

ocprop.jpg
ocprop.jpg (63.6 KiB) 761 mal betrachtet
"Folgefehler" in OCprop

wrtlbrmpft
Geocacher
Beiträge: 264
Registriert: Fr 8. Sep 2006, 13:31
Wohnort: 82008 Unterhaching

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von wrtlbrmpft » Mo 26. Mär 2018, 16:02

GS hat die Attribut-Icons von GIF auf PNG geändert. Damit findet geolog.pl die Attribute nicht mehr und lädt Schrott in die cache.txt.

Mit folgender kleinen Änderung ist das bei mir behoben:

Zeile 78 alt:

Code: Alles auswählen

 my ($version) = "2.93e";
Zeile 78 neu:

Code: Alles auswählen

 my ($version) = "2.93f";
Zeile 6560 alt:

Code: Alles auswählen

        $text =~ /\/images\/attributes\/(.*?)\.gif(.*)/si;
Zeile 6560 neu:

Code: Alles auswählen

        $text =~ /\/images\/attributes\/(.*?)\.png(.*)/si;
Dann läuft auch ocprop.pl wieder ohne Fehler durch.

Mir ist das etwa am 16.03.2018 aufgefallen. Alle falsch-geladenen Caches sollten mit der Option "r" nochmal geladen werden.

hjoe
Geocacher
Beiträge: 51
Registriert: Mo 6. Apr 2015, 10:46
Kontaktdaten:

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von hjoe » Mo 26. Mär 2018, 16:32

man bist Du schnell, Danke
mfg Heinz

Benutzeravatar
geomitast
Geocacher
Beiträge: 106
Registriert: Mi 1. Aug 2012, 16:12

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von geomitast » Di 27. Mär 2018, 10:49

Leute ihr seid einfach top hier!
Vielen Dank an "wrtbrmpft"!!!
Toll, dass geolog und ocprop nicht sterben!
Gerade zum Abgleich zwischen GC und OC gibt es (noch) nichts besseres. Wenn es mit GSAK gehen sollte bitte ich um Nachricht ;-)

NOCHMALS DANKE!!!

Gesendet von meinem SM-G900F mit Tapatalk


Benutzeravatar
Inder
Geowizard
Beiträge: 2451
Registriert: Di 27. Feb 2007, 17:31

Re: Fehlende oder fehlerhafte Felder beim Erstellen der html-Dateien

Beitrag von Inder » Di 3. Apr 2018, 22:52

Danke! Läuft wieder.
Logbuch erstellt mit Geolog.
Bekennender DNF-Logger

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder