Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Neue Version von Urwigo

Adventure-Cartridges für PDAs oder Garmin Colorado/Oregon

Moderator: m.zielinski

Charlenni
Geomaster
Beiträge: 755
Registriert: Di 17. Aug 2010, 15:27

Re: Neue Version von Urwigo

Beitrag von Charlenni » Mo 14. Apr 2014, 12:20

Update ist online als Version 1.19. Fehler ist damit behoben.

Werbung:
schnuefelis
Geonewbie
Beiträge: 5
Registriert: Di 1. Apr 2014, 08:03
Wohnort: Zürich

Re: Neue Version von Urwigo

Beitrag von schnuefelis » Mo 14. Apr 2014, 15:16

Ich bin interessanterweise vor ein paar Tagen auch auf dieses neue "feature" gestossen und hab' mir dann aber nichts weiter dabei gedacht.. :kopfwand: Ich habe den Input-Type halt einfach auf "Text" gesetzt und auf input == "5" geprüft. Funktioniert natürlich auch, ist aber halt ein bisschen :irre:
Zum Glück passen hier aber ein paar leute besser auf als ich :D

jonny65
Geomaster
Beiträge: 628
Registriert: Do 22. Sep 2011, 17:58

Re: Neue Version von Urwigo

Beitrag von jonny65 » Mo 14. Apr 2014, 19:03

Ja lieber einmal mehr hier posten, v.a bei solchen Hämmern. Man stelle sich mal vor ein Team aus 5 Leuten mit 50km Anfahrt nimmt sich heute den Wherigo vor und bleibt nach 20 Minuten bei einem Input hängen. Von der Schwere zu vergleichen, als wenn eine Zone nicht aktiviert wird.

Drum bin ich auch überhaupt nicht der Updatefan, v.a. wenn nix grundlegendes geändert wurde
oder keine neuen (für mich) sinnvollen Features eingebaut wurden. Ist in dem Fall ja obermegaübel : Cartridge bissl ändern, Zone anpassen, Rechtschreibfehler korrigieren oder sonstwas minimales, mit der neuen Version kompilieren und daraufhin funktionieren alle Zahlen Inputs nicht mehr. :shocked:

Wer klickt schon sein Spiel nach einer Miniänderung nochmal komplett durch v.a mit allen möglichen Fällen und Ereignissen ? :???:

Lästige Prävention ?
Die alten Urwigo Versionen stets behalten bzw. sichern.
Notieren welche Urwigo Version man zur Generierung des GWZ benutzt hat. Am besten ins Versionlog beim Upload auf wherigo.com eintragen.

Urwigo seitig wäre zu optimieren :
Die Seite selber sollte eine Downloadkategorie haben, die eine Historie aller Versionen enthält,
so daß man sofort downgraden kann, wenn es nötig ist.

Es müsste 1 Downloadpaket "UrwigoInst.exe" geben und nicht dieses suboptimale Webupdate.

Die Kommunikation Yourself <> charlenni ist aber erstklassig muss ich sagen. :2thumbs:

Charlenni
Geomaster
Beiträge: 755
Registriert: Di 17. Aug 2010, 15:27

Re: Neue Version von Urwigo

Beitrag von Charlenni » Mo 14. Apr 2014, 20:02

Deine Vorarbeit hat einiges erleichtert. Dadurch musste ich nur kurz nachschauen, was denn falsch läuft und das habe ich dann an Yourself weitergeleitet. So einfach ist das. Also Danke für's melden des Fehlers :gott: . Hat sicher viel Kopfzerbrechen vermieden.

Solche Probleme lassen sich nur dann vermeiden oder beheben, wenn verschiedene Leute Einblick in den Quellcode haben. Aber Open Source ist Urwigo ja nicht. Vielleicht kann sich Yourself ja mal dazu durchringen :roll: .

whiterussian_ch
Geomaster
Beiträge: 308
Registriert: Mi 13. Apr 2011, 22:07

Re: Neue Version von Urwigo

Beitrag von whiterussian_ch » Mo 14. Apr 2014, 21:33

Gerade das Update gemacht.

Die Zahl-Eingabe, die mit der letzten Version davor nicht mehr funktioniert hat, geht nun wieder. Dafür glaube ich einen neuen Bug gefunden zu haben.

Ich habe bei einem Gegenstand eine "Benutzen mit"-Verknüpfung. Ich bin mir relativ sicher, dass die bei der vor-vorletzen Version noch funktioniert hat (relativ sicher, weil sie sicher mal irgendwann funktioniert hat und ich da seit Ewigkeiten nichts mehr dran geschraubt habe).

Klicke ich da jetzt drauf, passiert genau gar nix.

Wie sieht das bei euch aus? Funktionieren "Benutzen Mit"-Geschichten?

Und an dieser Stelle vielleicht nochmals die Frage von heute Morgen: Gibt es irgendeine Möglichkeit wieder downzugraden?

Charlenni
Geomaster
Beiträge: 755
Registriert: Di 17. Aug 2010, 15:27

Re: Neue Version von Urwigo

Beitrag von Charlenni » Mo 14. Apr 2014, 22:22

Hier wäre ein Vorher-Nachher Vergleich sehr schön: Wie sah es vorher in der Lua Datei aus, wie nachher?

Gibt es zu dem Problem die zwei Lua, GWZ oder GWC Dateien? Dann kann man einen Vergleich starten.

Wegen den Vorgänger-Versionen frage ich nach.

whiterussian_ch
Geomaster
Beiträge: 308
Registriert: Mi 13. Apr 2011, 22:07

Re: Neue Version von Urwigo

Beitrag von whiterussian_ch » Mo 14. Apr 2014, 22:24

Nein, ich habe leider keine Vorher-Dateien mehr. Ich habe noch ein Backup der Urwigo-Projektdatei. Würde das helfen? Eher nicht oder?

Charlenni
Geomaster
Beiträge: 755
Registriert: Di 17. Aug 2010, 15:27

Re: Neue Version von Urwigo

Beitrag von Charlenni » Mo 14. Apr 2014, 22:29

Aber die alte GWC Datei, die man herunterladen kann und eine neu erzeugte GWC Datei mit der neuen Version würden mir reichen.

Oder alternativ ein einfaches Beispiel, bei dem es nicht funktioniert ;)

jonny65
Geomaster
Beiträge: 628
Registriert: Do 22. Sep 2011, 17:58

Re: Neue Version von Urwigo

Beitrag von jonny65 » Mo 14. Apr 2014, 22:55

Habs grad nachvollziehen können. Es tritt schon mal auf, wenn das Ziel mit "Command target" verglichen wird. Messer ist mit Schleifstein verknüpft und hat das Target Schleifstein. Messer hat den Befehl "Benutze mit". D.h ohne der Reciprocal Funktion haben beide Items jetzt den Befehl "Benutze mit". Kommt nun beim Kommando "Benutze mit" die Abfrage if Command target = Schleifstein passiert nix, d.h der if Zweig wird nicht durchlaufen. Ebenso andersrum, also benutze Schleifstein mit Messer. Ging vorher (1.15 oder 1.16) auf jeden Fall, sonst hätte ich seit Wochen böse DNFs :motz: Bei der Stelle wo ich auch eine Verknüpfung habe, aber nicht mit Command target abfrage, funktionierts.

Nachzuvollziehen auch mit dem Wiki Beispiel "Items nehmen und geben (Variante 1 mit Objektverknüpfung)"

http://www.das-wherigo-handbuch.de/inde ... psel#Items
http://www.das-wherigo-handbuch.de/imag ... eben_1.zip

Ich kann dem Bauern die Axt nicht geben :kopfwand: :irre:

jonny65
Geomaster
Beiträge: 628
Registriert: Do 22. Sep 2011, 17:58

Re: Neue Version von Urwigo

Beitrag von jonny65 » Mo 14. Apr 2014, 23:07

whiterussian_ch hat geschrieben: Und an dieser Stelle vielleicht nochmals die Frage von heute Morgen: Gibt es irgendeine Möglichkeit wieder downzugraden?
Irgendwie nicht so ganz oder mit großem Gepfriemel. Hab das Gefühl daß seit neuestem alte Installationen gelöscht werden, die vorher immer noch in Parallelverzeichnissen in den Tiefen der User Verzeichnisse waren, z.b sowas hier :

c:\Users\jonny\AppData\Local\Apps\2.0\MJZWCVWA.PY9\EX59ADL7.BTC\urwi..tion_f37633858e53e440_0001.0012_60e3557bcf60a573\

und darüber noch 1 Verzeichnis, das mit "urwigo.exe_" beginnt und 1 Verzeichnis mit Manifests. Man erkennt die, die zusammengehören, am Timestamp.

Files zum selber pflücken gäbs auch hier : http://apps.yourself.cz/Urwigo/Application%20Files/
vorausgesetzt Yourself macht hier nicht zu :/
Die setup.exe zum starten des Updates liegt da auch in http://apps.yourself.cz/Urwigo/

Antworten