Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Timer auf dem iphone funktioniert nicht

Adventure-Cartridges für PDAs oder Garmin Colorado/Oregon

Moderator: m.zielinski

hefi1
Geocacher
Beiträge: 14
Registriert: Mo 12. Jan 2009, 09:33

Timer auf dem iphone funktioniert nicht

Beitrag von hefi1 »

Ich bin gerade dabei ein wherigo zu programmieren mit urwigo.
habe jetzt einen testlauf mit dem iphone gemacht und einen fehler festgestellt.
Bei ende soll die verbleibene Zeit angezeigt werden! in dem urwigo-player funktioniert das, aber bei dem iphone ist die Antwort immer 0! woran kann das liegen?
(Als Befehl habe ich einen Dialog gewählt und da aus dem timer "verbleibene Zeit" rein gezogen)
danke schonmal für eure hilfe!
lg hefi
Benutzeravatar
tower27
Geowizard
Beiträge: 1035
Registriert: So 6. Apr 2008, 22:01
Wohnort: Saarland

Re: Timer auf dem iphone funktioniert nicht

Beitrag von tower27 »

Sieht leider wirklich so aus, als ob PiGo ein Problem mit Timern hätte. Habe heute leider ein entsprechendes Log bei einem meiner Wherigos "geerntet".
Benutzeravatar
Team Eifelyeti
Geomaster
Beiträge: 623
Registriert: Mo 11. Jun 2007, 15:47
Wohnort: 52156 Monschau

Re: Timer auf dem iphone funktioniert nicht

Beitrag von Team Eifelyeti »

Die Situation hatten wir vergangene Woche auch bei einm Wherigo. Ein 2 Minuten Timer wurde gestartet. Keinerlei Gimmicks a la Restzeitanzeige oder ähnliches, nur Timer gestartet. Eierphone (TM) OS 4.3.2 und PiGo, neueste Version, sind ausgestiegen. :motz: (aber nicht über den Owner, sondern über PiGo und Eierphone(TM) ;) )

Gottseidank hatten wir den Oregon im EInsatz, der dies gemeistert hat :D

Preisfrage - hat schon irgendwer eine Ahnung, woran dies liegt, oder ist das Eierphone (TM) einfach Timerresistent? Wäre schade, da ich meine bisherigen Wherigos alle Eierphonefähig hinbekommen habe und bei meinem nächsten Projekt auch einen Timer einsetzen möchte.

Viele Grüße
Team Eifelyeti
Eifel - I love it
Mein Wunschkennzeichen für's Auto: EIF-EL ...
Benutzeravatar
izaseba
Geomaster
Beiträge: 963
Registriert: Fr 1. Aug 2008, 00:14
Wohnort: 47661 Issum

Re: Timer auf dem iphone funktioniert nicht

Beitrag von izaseba »

Hallo,

Wie wirkt sich dieser Fehler den aus?
Wir haben vor kurzem ein Log bei unserem Wherigo bekommen, dass jemand mit so einem Eiermoped da gewesen war und problemlos alles durchspielen konnte.
Auch wir haben dort eine nette Timer Spielerei eingebaut und jetzt bin ich ein wenig verwundert.

Gruß Sebastian
Benutzeravatar
Team Eifelyeti
Geomaster
Beiträge: 623
Registriert: Mo 11. Jun 2007, 15:47
Wohnort: 52156 Monschau

Re: Timer auf dem iphone funktioniert nicht

Beitrag von Team Eifelyeti »

izaseba hat geschrieben:Hallo,

Wie wirkt sich dieser Fehler den aus?
Wir haben vor kurzem ein Log bei unserem Wherigo bekommen, dass jemand mit so einem Eiermoped da gewesen war und problemlos alles durchspielen konnte.
Auch wir haben dort eine nette Timer Spielerei eingebaut und jetzt bin ich ein wenig verwundert.

Gruß Sebastian
Hallo Sebastian,

also - wir haben eine Zone betreten und dann poppte eine Message auf "der Ladevorgang dauert 2 Minuten" (Ich vermute, beim betreten der Zone wurde ein 120 Sekunden Countdowntimer gestartet).
Das Messagefenster hatte einen "OK" Button.

Beim Drücken dieses Buttons wurde auf dem Iphone immer wieder dieses Messagefenster eingeblendet, auch nach Ablauf von 2 Minuten. Da wir Zeit hatten, haben wir dies mal gut 5 Minuten probiert, ohne Erfolg. Dann haben wir die Catridge auf dem Iphone "aborted", was auch ziemlich lange dauerte, ehe es in die PiGo Übersichtsseite gesprungen ist

Auf dem Oregon sprang das Programm während der 2 Minuten ebenfalls wieder auf die Message, wenn "OK" gedrückt wurde, nach Ablauf der 2 Minuten aber in einen anderen Screen (weiß jetzt nicht mehr, ob Mainscreen, oder nächstes Messagefenster), so wie's zu erwarten war.

Besser kann ich es nicht beschreiben.

Habe aber gerade mal einen Timertest in Urwigo erstellt (Countdown und on elapsed Anzeige der nächsten Zone). Auf dem Oregon läuft's, Eierphone(TM) werde ich heute nachmittag mal testen.

Viele Grüße
Herbert
Eifel - I love it
Mein Wunschkennzeichen für's Auto: EIF-EL ...
Benutzeravatar
izaseba
Geomaster
Beiträge: 963
Registriert: Fr 1. Aug 2008, 00:14
Wohnort: 47661 Issum

Re: Timer auf dem iphone funktioniert nicht

Beitrag von izaseba »

Hallo,
für mich sieht es so aus, als ob der Timer bei dem Eierphone garnicht erst gestartet wird.
Ich sag mal so, bei unserem Wherigo hat das den Leuten einiges an sag ich mal Spaß erspart :ops:
Vielleicht soll man da den Entwickler dieser Software anschreiben, es ist wohl ein Bug :???:

Gruß Sebastian
Lamanto
Geonewbie
Beiträge: 6
Registriert: Di 28. Jun 2011, 08:56

Re: Timer auf dem iphone funktioniert nicht

Beitrag von Lamanto »

Ich habe gerade ein ähnliches Problem mit einem kürzlich veröffentlichten Wherigo. Der Timer funktioniert bei i-Phones nicht.

Ich habe die Programmierer der i-Phone-App angeschrieben und war positiv überrascht von der prompten Reaktion. Ergebnis ist, dass bei der App wohl jedes mal, wenn der Timer gestoppt wird die "remaining time" auf null gesetzt wird.

Da ich den Spieler zurück schicke, wenn diese null ist, geht es an dieser Stelle mit dem i-Phone nicht weiter.

Vielleicht hilft die Info Euch ja bei ähnlichen Problemen.

Der Programmierer von Pi-Soft hat mir übrigens versprochen, dass sie den Bug beim nächsten Update der App korrigieren werden.
Benutzeravatar
Krolock
Geocacher
Beiträge: 227
Registriert: Fr 14. Jan 2011, 09:31

Re: Timer auf dem iphone funktioniert nicht

Beitrag von Krolock »

Lamanto hat geschrieben:... dass bei der App wohl jedes mal, wenn der Timer gestoppt wird die "remaining time" auf null gesetzt wird.
Hallo Lamento,
vielen Dank für die Info.

Was heißt bei dir Timer gestoppt? Nur 'On stop' oder auch auch 'On elapse'?
Ist null bei dir nil oder 0 ?
Lamanto
Geonewbie
Beiträge: 6
Registriert: Di 28. Jun 2011, 08:56

Re: Timer auf dem iphone funktioniert nicht

Beitrag von Lamanto »

Hallo Krolock,

ich stecke leider nicht so in der Syntax drin, weil ich den Wherigo mit dem grafischen Urwigo-Builder erstellt habe (und dazu noch mit der deutschen Oberfläche).

Gemeint war bei ein Befehl, der den Timer stoppt - also 'On stop'. Bei 'On elapsed' sollte die 'remaining time' sowieso auf '0' stehen. Was immer dann das i-Phone damit macht.

Da die 'remaining time'-Variable numerisch ist, würde ich sagen es ist '0' und nicht 'nil'. Bei meinem Wherigo kommt jedenfalls die Message für den Fall 'remaining time'='0'. Aber, wie gesagt, ich bewege mich bisher nur auf der grafischen Oberfläche des Urwigo-Builders.
Benutzeravatar
xxmurdockxx
Geomaster
Beiträge: 555
Registriert: Do 9. Okt 2008, 19:38
Wohnort: Memmingen

Re: Timer auf dem iphone funktioniert nicht

Beitrag von xxmurdockxx »

Seltsam,

mache auch grad einen Wherigo und dort ist ein Timer drin.
Timer startet und nach 300 Sekunden und bei Ablauf kommt halt eine Meldung Blabla...
Während dieser Zeit muß in einderen Zone etwas geholt werden und zurück.

Gestern getestet und hat mit dem PiGo anstandslos funktioniert. :???:
Hatten beide Fälle.
einmal innerhalb der Zeit den Gegenstand geholt und zurück zur Ausgangszone - klappte
einmal ist der Timer abgelaufen - hat auch geklappt.

Das Ganze wurde nur mit dem Urwigo gemacht.
Bild Bild
Antworten